import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+)\\s+(\\w+)\\s+(\\w+).*?\\r?\\n•\\s+(.*?)\\s+[0-9]+\\s\\|.*\\s*";
final String string = "1 el art the\n"
+ "• esa mujer era la mujer que yo quería ser\n"
+ "100 | 2037803\n\n"
+ "2 de prep of, from\n"
+ "• el hijo de un hermano mío\n"
+ "100 | 1319834\n\n"
+ "3 que conj that, which\n"
+ "• dice que no\n"
+ "100 | 662653";
final String subst = "\\1\\t\\2\\t\\3\\t\\4\\t\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}