re = /([0-9]+)\s+(\w+)\s+(\w+).*?\r?\n•\s+(.*?)\s+[0-9]+\s\|.*\s*/
str = '1 el art the
• esa mujer era la mujer que yo quería ser
100 | 2037803
2 de prep of, from
• el hijo de un hermano mío
100 | 1319834
3 que conj that, which
• dice que no
100 | 662653'
subst = '\\1\\t\\2\\t\\3\\t\\4\\t\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result