import re
regex = re.compile(r"""
(?P<nested>
\b if \b
(?P<if>(?>.?(?>(?P>nested))?)*?)
(?:
\b elsif \b
(?P<elsif>(?>.?(?>(?P>nested))?)*?)
)?
(?:
\b else \b
(?P<else>(?>.?(?>(?P>nested))?)*?)
)?
\b endif \b
)?
""", flags=re.IGNORECASE | re.VERBOSE | re.DOTALL)
test_str = ("if\n"
" 1\n"
" if\n"
" 2\n"
" elsif\n"
" 2\n"
" else\n"
" 2\n"
" if\n"
" 3\n"
" endif\n"
" 2\n"
" endif\n"
" 1\n"
" if\n"
" 2\n"
" else\n"
" 2\n"
" endif\n"
" 1\n"
"elsif\n"
" 1_elsif1_\n"
"elsif\n"
" 1_elsif2_\n"
"else\n"
" 1_else_\n"
"endif")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")