$re = '/\w{2}\d/\d{1,2}(?:/\d{1,2})?/m';
$str = 'Gi1/0/1 Fa0/1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);