package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\*\*\B`)
var str = `Th**is is a **text** test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}