package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\s+\S+\s+\|\s+\S+\s+\|\s+([^\\|]*)\s+\|.*$`)
var str = `abcd abcd | abcde | Degree SP | xyz abcd | abcd ABC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}