re = /^.*?\s+\S+\s+\|\s+\S+\s+\|\s+([^\\|]*)\s+\|.*$/m
str = 'abcd abcd | abcde | Degree SP | xyz abcd | abcd ABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end