using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"value=""(\d+),\s*(\d+),\s*(\d+),\s*(\d+)""";
string input = @"<classifier id=""box-geometry"" value=""476,736,703,997"" />
<classifier id=""box-geometry"" value=""476,736,703, 997"" />
<classifier id=""box-geometry"" value=""476, 736, 703, 997"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}