import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>,|\\G(?!\\A) +AND) +\\K(?>(?! +AND).)+";
final String string = "NETHERLANDS (THE)\n"
+ "BOLIVIA (PLURINATIONAL STATE OF)\n"
+ "COCOS (KEELING) ISLANDS (THE)\n"
+ "ANTIGUA AND BARBUDA\n\n"
+ "TEST1, SOME TEXT\n"
+ "TEST2, SAINT HELENA AND ASCENSION AND TRISTAN DA CUNHA\n"
+ "TEST3, BONAIRE AND SINT EUSTATIUS AND SABA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}