import re
regex = re.compile(r"(?>,|\G(?!\A) +AND) +\K(?>(?! +AND).)+", flags=re.MULTILINE)
test_str = ("NETHERLANDS (THE)\n"
"BOLIVIA (PLURINATIONAL STATE OF)\n"
"COCOS (KEELING) ISLANDS (THE)\n"
"ANTIGUA AND BARBUDA\n\n"
"TEST1, SOME TEXT\n"
"TEST2, SAINT HELENA AND ASCENSION AND TRISTAN DA CUNHA\n"
"TEST3, BONAIRE AND SINT EUSTATIUS AND SABA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")