package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^:]+):(\d+):(.+)`)
var str = `src/sample.js:10:This is the message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}