$re = '/([^:]+):(\d+):(.+)/m';
$str = 'src/sample.js:10:This is the message';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);