import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+\\.com\\/mn$";
final String string = "http://www.foo.com/mn\n"
+ "http://www.foodev.com/mn\n"
+ "http://www.foo.com/MN\n"
+ "http://www.foodev.com/MN\n\n"
+ "http://www.foo.com/la/mn \n"
+ "http://www.foo.com/la/di/da/mn \n"
+ "http://www.foodev.com/la/mn \n"
+ "http://www.foodev.com/la/di/da/mn";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}