# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.+\.com\/mn$"
test_str = ("http://www.foo.com/mn\n"
"http://www.foodev.com/mn\n"
"http://www.foo.com/MN\n"
"http://www.foodev.com/MN\n\n"
"http://www.foo.com/la/mn \n"
"http://www.foo.com/la/di/da/mn \n"
"http://www.foodev.com/la/mn \n"
"http://www.foodev.com/la/di/da/mn")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.