$re = '/^\+?998?\s?-?(20|33|36|50|55|61|62|65|66|67|69|70|71|72|73|74|75|76|77|78|79|88|90|91|93|94|95|97|98|99)\s?-?(\d{3})\s?-?(\d{2})\s?-?(\d{2})$/';
$str = '99890-364-19-05
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);