import Foundation
let pattern = #"^\+?998?\s?-?(20|33|36|50|55|61|62|65|66|67|69|70|71|72|73|74|75|76|77|78|79|88|90|91|93|94|95|97|98|99)\s?-?(\d{3})\s?-?(\d{2})\s?-?(\d{2})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
99890-364-19-05
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}