import Foundation
let pattern = #"\s\[[^\]]+\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Привет! Мой любимый [любимий] магазин - Таргет. Он находится в El Con центре [сентре] Тусоне. Вы [ви] можете купить практически [пратически] все, что вы хотите. Например, игрушки. Очень круто! Мужскую, женскую и даже детскую одежду. Вы также можете купить электронику и больше. Таргет - дешевый [дешевий] и дорогой магазин, но это только иногда дорог дорого. Мне нравится их одежда и симпатичные работники. Я иногда хожу в Таргет, и я думаю, что многим нравится ходить туда. Мужчинам, женщинам и детям. Здесь есть даже Старбакс и Pizza Hut.
<1:33>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)