#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)({{|}}|(?:(?!{{|}})[^ ])+(?!({{(?2)*?}}|(?:(?!{{|}}).)*)*$))"
Local $sString = "{{}}" & @CRLF & _
"aaa {{}}" & @CRLF & _
"{{aaa}}" & @CRLF & _
"{{aa}} {{bbb}}" & @CRLF & _
"{{aaa {{ bb }} }}" & @CRLF & _
"{{aa {{ bbb {{ c }} }} }}" & @CRLF & _
"{{a{a}{{ b{b}b {{ c }} }} }}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")