using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({{|}}|(?:(?!{{|}})[^ ])+(?!({{(?2)*?}}|(?:(?!{{|}}).)*)*$))";
string input = @"{{}}
aaa {{}}
{{aaa}}
{{aa}} {{bbb}}
{{aaa {{ bb }} }}
{{aa {{ bbb {{ c }} }} }}
{{a{a}{{ b{b}b {{ c }} }} }}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}