import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?!(\\{\\{(?1)*?\\}\\}|(?:(?!\\{\\{|\\}\\}).)*)*+$)(*COMMIT)(*F))?(\\{\\{|\\}\\}|(?:(?!\\{\\{|\\}\\})[^ ])+(?!(\\{\\{(?3)*?\\}\\}|(?:(?!\\{\\{|\\}\\}).)*)*+$))";
final String string = "aaa }}\n"
+ "{{}}\n"
+ "aaa {{}}\n"
+ "{{aaa}}\n"
+ "{{aa}} {{bbb}}\n"
+ "{{aaa {{ bb }} }}\n"
+ "{{aa {{ bbb {{ c }} }} }}\n"
+ "{{a{a}{{ b{b}b {{ c }} }} }}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}