re = /(?:^(?!({{(?1)*?}}|(?:(?!{{|}}).)*)*+$)(*COMMIT)(*F))?({{|}}|(?:(?!{{|}})[^ ])+(?!({{(?3)*?}}|(?:(?!{{|}}).)*)*+$))/m
str = 'aaa }}
{{}}
aaa {{}}
{{aaa}}
{{aa}} {{bbb}}
{{aaa {{ bb }} }}
{{aa {{ bbb {{ c }} }} }}
{{a{a}{{ b{b}b {{ c }} }} }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end