re = /("?)key\1.*?"(.*?)"/
str = 'blahblah "key":"value","TargetCRS": "Target","TargetCRScode": "vertical Code","zzz": "aaaa" sadzxc "sss"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end