package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w{2})?\s*(\w)?`)
var str = `AD
Y
E
AD E
WZ E`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}