$re = '/(\w{2})?\s*(\w)?/m';
$str = 'AD
Y
E
AD E
WZ E';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);