package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4}[ -]+\d{2})(\d{2}(?:[ -]*)\d{4})`)
var str = `4500-1234-5678-7654`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}