$re = '/^(\d{4}[ -]+\d{2})(\d{2}(?:[ -]*)\d{4})/m';
$str = '4500-1234-5678-7654';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);