import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=fn)[^\\\\]*(?=\\)|\\\\fn)";
final String string = "\\t(\\fnJester (BIG))\n"
+ "\\t(\\fnJester (BIG))\\i1 \n"
+ "\\t(\\fnJester (BIG)\n"
+ "\\t(\\fnJester))))\\fnArial (BOLD)\\\n"
+ "\\t(\\fnJester))))\\fnArial (BOLD)\\fnArial (BOLD)\\\n"
+ "\\t(\\fnJester))))\\fnArial (BOLD)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}