$re = '/(?<=fn)[^\\\\]*(?=\)|\\\\fn)/m';
$str = '\\t(\\fnJester (BIG))
\\t(\\fnJester (BIG))\\i1
\\t(\\fnJester (BIG)
\\t(\\fnJester))))\\fnArial (BOLD)\\
\\t(\\fnJester))))\\fnArial (BOLD)\\fnArial (BOLD)\\
\\t(\\fnJester))))\\fnArial (BOLD)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);