$re = '/(?<key>\w+)\h*=\h*(?:"(.*?)"|([^"\r\n]+));$/m';
$str = 'NumericValue = 123456;
Comment = "This is a comment";
NumericValue = 123456;
Comment = "This is a "comment"; This is still a comment";
Comment = "This is a "comment"; Th"""J;;;j;;jj\'"""is is still a comment";
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);