re = /(?<key>\w+)\h*=\h*(?:"(.*?)"|([^"\r\n]+));$/m
str = 'NumericValue = 123456;
Comment = "This is a comment";
NumericValue = 123456;
Comment = "This is a "comment"; This is still a comment";
Comment = "This is a "comment"; Th"""J;;;j;;jj\'"""is is still a comment";
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end