package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*(\d|[1-9]\d+)(\s+(\d|[1-9]\d+)){2}(\s+((0x(\d|[a-f]|[A-F}]){1,8})|[1-9]\d+|\d))*\s*$`)
var str = `2 4 3 0xff0000 0xffff00 0x007700 0xff0077 0x0000ff 0xff7700 0x00ff77 0x888888`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}