const regex = /^\s*(\d|[1-9]\d+)(\s+(\d|[1-9]\d+)){2}(\s+((0x(\d|[a-f]|[A-F}]){1,8})|[1-9]\d+|\d))*\s*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(\\d|[1-9]\\d+)(\\s+(\\d|[1-9]\\d+)){2}(\\s+((0x(\\d|[a-f]|[A-F}]){1,8})|[1-9]\\d+|\\d))*\\s*$', 'g')
const str = `2 4 3 0xff0000 0xffff00 0x007700 0xff0077 0x0000ff 0xff7700 0x00ff77 0x888888`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}