use strict;
my $str = ' E6U5 Z339988 T8 N55
886 W 9ZT T95';
my $regex = qr/(?<flag>E|W\s)?(?<id>[a-z0-9]{1,4})(?<errorcode>\s[a-z0-9]{5,})?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}