$re = '/(?<flag>E|W\s)?(?<id>[a-z0-9]{1,4})(?<errorcode>\s[a-z0-9]{5,})?/mi';
$str = ' E6U5 Z339988 T8 N55
886 W 9ZT T95';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);