const regex = /(?:file-name=.*)(\..+)(?:&)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:file-name=.*)(\\..+)(?:&)', 'gm')
const str = `www.xyz.com/private/videos/89FDJKDKFgrFTD-MUyKE9Sn/source?file-name=SampleAudio_0.4mb.mp3&token=exp=1591202847~acl=/private/videos/8OJFREFJOIJFREJ-MUyKE9Sn/source*~hmac=aef161514cdfodsjfodsjorjef081b4c849b8c29c6a37339803866badfd4a16`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}