re = /(?:file-name=.*)(\..+)(?:&)/m
str = 'www.xyz.com/private/videos/89FDJKDKFgrFTD-MUyKE9Sn/source?file-name=SampleAudio_0.4mb.mp3&token=exp=1591202847~acl=/private/videos/8OJFREFJOIJFREJ-MUyKE9Sn/source*~hmac=aef161514cdfodsjfodsjorjef081b4c849b8c29c6a37339803866badfd4a16'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end