package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\d{2}.\d{2}\]|\d{2}\.\d{2}`)
var str = `[12.00]12.00
[abc]10.45
[34.56]abc
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}