$re = '/\[\d{2}.\d{2}\]|\d{2}\.\d{2}/m';
$str = '[12.00]12.00
[abc]10.45
[34.56]abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);