// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]+\s((\/\w+)*\/)([\w\-\.]+[^#?\s]+)").unwrap();
let string = "GET /context/path/to/file.js
https://stackoverflow.com/questions/27745/getting-parts-of-a-url-regex";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}