const regex = /^[a-zA-Z]{2}\d{6}-[1-9]\d$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]{2}\\d{6}-[1-9]\\d$', 'gm')
const str = `Be123456-19
aBe123456-19`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}