$re = '/^[a-zA-Z]{2}\d{6}-[1-9]\d$/m';
$str = 'Be123456-19
aBe123456-19';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);