import re
regex = re.compile(r"^(I1|I2|I3|I4|I5|I6|II|III|IV|V|VI|VII|VIII|IX|X|XI|XII|XIII|XIV|XV|XVI|XVII|XVIII|XIX)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("I1\n"
"I2\n"
"I3\n"
"I4\n"
"I5\n"
"I6\n"
"II\n"
"III\n"
"IV\n"
"V\n"
"VI\n"
"VII\n"
"VIII\n"
"IX\n"
"X\n"
"XI\n"
"XII\n"
"XIII\n"
"XIV\n"
"XV\n"
"XVI\n"
"XVII\n"
"XVIII\n"
"XIX")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")