$re = '~/\K\w++(?!/)~m';
$str = 'adadds/asdsd/foo aeee/ggdgg/bar aff/ggg/ddafs/afdf/doo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);