re = /\/\K\w++(?!\/)/m
str = 'adadds/asdsd/foo aeee/ggdgg/bar aff/ggg/ddafs/afdf/doo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end