#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+(?:\.[\d{1,2}]*)?|\.[\d{1,2}]+)(?:,[\s]?(?:\d+(?:\.[\d{1,2}]*)?|\.[\d{1,2}]+))*$"
Local $sString = "0" & @CRLF & _
"12345" & @CRLF & _
"12345,23456,34567,45678" & @CRLF & _
"12345,23456,34567,45678" & @CRLF & _
"12345, 23456, 34567,4567" & @CRLF & _
"12345, 23456, 34567, 4567," & @CRLF & _
"12345, 23456, 34567, 4567," & @CRLF & _
"1,,2," & @CRLF & _
"1.3345345" & @CRLF & _
"1.2, 1.3" & @CRLF & _
"2.0124" & @CRLF & _
"2." & @CRLF & _
"0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")