$re = '/^(?:\d+(?:\.[\d{1,2}]*)?|\.[\d{1,2}]+)(?:,[\s]?(?:\d+(?:\.[\d{1,2}]*)?|\.[\d{1,2}]+))*$/m';
$str = '0
12345
12345,23456,34567,45678
12345,23456,34567,45678
12345, 23456, 34567,4567
12345, 23456, 34567, 4567,
12345, 23456, 34567, 4567,
1,,2,
1.3345345
1.2, 1.3
2.0124
2.
0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);