import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'([\\p{L}]+)";
final String string = "'가락시장(340)',\n"
+ " '가락시장(8)',\n"
+ " '가산디지털단지(7)',\n"
+ " '강남(222)',\n"
+ " '강남구청',\n"
+ " '강동',\n"
+ " '강동구청',\n"
+ " '강변(214)',\n"
+ " '개롱',\n"
+ " '개화산',\n"
+ " '거여',\n"
+ " '건대입구(212)',\n"
+ " '건대입구(7)',\n"
+ " '경복궁(317)',\n"
+ " '경찰병원(341)',\n"
+ " '고덕',\n"
+ " '고려대',\n"
+ " '고속터미널(329)',\n"
+ " '고속터미널(7)',\n"
+ " '공덕(5)',\n"
+ " '공덕(6)',\n"
+ " '공릉',\n"
+ " '광나루',";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}