package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\.\S+:?\b`)
var str = `a.abc
a.abc:bcd
a.abc: bcd
.abc
.abc:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}