using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(source=(\d+))";
string input = @"100, source=100,10, delta=10, 2020, source=2020";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}