$re = '/(source=(\d+))/m';
$str = '100, source=100,10, delta=10, 2020, source=2020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);